Print the tree of processes

Processes and their PID numbers

A running program is called a process. On macOS, Linux, and Microsoft Windows, every process has a unique identifying number called a PID. “Unique” means that you never have two processes running at the same time with the same PID number. Similiarly, you never have two motor vehicles running at the same time with the same New York State license plate.

The processes are organized into a family tree. In other words, every process has a parent process, and a process can have one or more child processes. For example, Google Chrome (PID 552) has eight children. Can you find them? And my Terminal (PID 652) has two children, because I currently have two Terminal windows open. Can you find them?

The process at the top of the tree is always the process whose PID is 0. This process is its own parent. No other process is its own parent.

Each line output by ps (except for the header line) consists of the PID number of a process, the PID number of the parent of that process, and the process’s command line. If the name of the command in the command line ends with a “d” (e.g., /usr/sbin/syslogd), then the process is probably a dæmon.

ps -A -o 'pid ppid command'
  PID  PPID COMMAND
    1     0 /sbin/launchd
   49     1 /usr/libexec/UserEventAgent (System)
   50     1 /usr/sbin/syslogd
   52     1 /System/Library/PrivateFrameworks/Uninstall.framework/Resources/uninstalld
   53     1 /usr/libexec/kextd
   54     1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/FSEvents.framework/Versions/A/Support/fseventsd
   56     1 /System/Library/PrivateFrameworks/MediaRemote.framework/Support/mediaremoted
   59     1 /System/Library/CoreServices/appleeventsd --server
   60     1 /usr/libexec/configd
   61     1 /System/Library/CoreServices/powerd.bundle/powerd
   62     1 /usr/libexec/mobileassetd
   67     1 /usr/libexec/logd
   71     1 /usr/libexec/airportd
   73     1 /usr/libexec/warmd
   74     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Support/mds
   78     1 /System/Library/CoreServices/iconservicesd
   79     1 /System/Library/CoreServices/iconservicesagent
   82     1 /usr/libexec/diskarbitrationd
   85     1 /usr/libexec/coreduetd
   86     1 /usr/libexec/wdhelper
   91     1 /usr/libexec/opendirectoryd
   92     1 /usr/sbin/wirelessproxd
   94     1 /System/Library/PrivateFrameworks/ApplePushService.framework/apsd
   95     1 /System/Library/PrivateFrameworks/Noticeboard.framework/Versions/A/Resources/nbstated
   96     1 /System/Library/CoreServices/launchservicesd
   97     1 /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/Resources/usbmuxd -launchd
   98     1 /usr/sbin/securityd -i
  100     1 /usr/libexec/locationd
  102     1 /usr/libexec/DuetHeuristic-BM
  103     1 /usr/libexec/displaypolicyd -k 1
  104     1 /usr/sbin/blued
  105     1 autofsd
  109     1 /System/Library/PrivateFrameworks/GenerationalStorage.framework/Versions/A/Support/revisiond
  110     1 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
  111     1 /System/Library/CoreServices/logind
  112     1 /usr/sbin/KernelEventAgent
  114     1 /usr/libexec/hidd
  115     1 /usr/libexec/corebrightnessd --launchd
  116     1 /usr/libexec/AirPlayXPCHelper
  117     1 /usr/sbin/notifyd
  118     1 /usr/sbin/distnoted daemon
  124     1 /usr/sbin/cfprefsd daemon
  149     1 /System/Library/CoreServices/coreservicesd
  150     1 aslmanager
  152     1 /System/Library/Frameworks/Security.framework/Versions/A/XPCServices/authd.xpc/Contents/MacOS/authd
  155     1 /System/Library/Frameworks/PCSC.framework/Versions/A/XPCServices/com.apple.ctkpcscd.xpc/Contents/MacOS/com.apple.ctkpcscd
  159     1 /System/Library/Frameworks/CryptoTokenKit.framework/ctkd -s
  161     1 /usr/libexec/trustd
  174     1 /usr/libexec/sandboxd
  183     1 /System/Library/PrivateFrameworks/SkyLight.framework/Resources/WindowServer -daemon
  184     1 /usr/sbin/mDNSResponder
  189     1 /usr/libexec/lsd runAsRoot
  192     1 /usr/sbin/mDNSResponderHelper
  198     1 /usr/libexec/findmydeviced
  204     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mds_stores
  207     1 /System/Library/PrivateFrameworks/WirelessDiagnostics.framework/Support/awdd
  209     1 /usr/libexec/amfid
  300     1 /System/Library/PrivateFrameworks/AmbientDisplay.framework/Versions/A/XPCServices/com.apple.AmbientDisplayAgent.xpc/Contents/MacOS/com.apple.AmbientDisplayAgent
  302     1 /usr/sbin/coreaudiod
  303     1 /usr/sbin/systemstats --xpc
  304     1 /System/Library/CoreServices/CrashReporterSupportHelper server-init
  305     1 /usr/libexec/nsurlsessiond --privileged
  306     1 /usr/libexec/nehelper
  307     1 /usr/sbin/ntpd -c /private/etc/ntp-restrict.conf -n -g -p /var/run/ntpd.pid -f /var/db/ntp.drift
  308     1 /usr/libexec/corestoraged
  309     1 /usr/libexec/usbd
  310     1 /usr/libexec/thermald
  311     1 /System/Library/CryptoTokenKit/com.apple.ifdreader.slotd/Contents/MacOS/com.apple.ifdreader
  312     1 /System/Library/Frameworks/CoreMediaIO.framework/Resources/VDC.plugin/Contents/Resources/VDCAssistant
  320     1 /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/CVMServer
  323     1 /System/Library/Frameworks/CoreAudio.framework/Versions/A/XPCServices/com.apple.audio.DriverHelper.xpc/Contents/MacOS/com.apple.audio.DriverHelper
  326     1 /System/Library/Frameworks/Security.framework/Versions/A/XPCServices/com.apple.CodeSigningHelper.xpc/Contents/MacOS/com.apple.CodeSigningHelper
  334     1 /usr/libexec/symptomsd
  336     1 /usr/libexec/nsurlstoraged
  355     1 /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd
  359     1 /System/Library/Frameworks/CryptoTokenKit.framework/ctkahp.bundle/Contents/MacOS/ctkahp -d
  360     1 /usr/libexec/secinitd
  362     1 /System/Library/PrivateFrameworks/PerformanceAnalysis.framework/Versions/A/XPCServices/com.apple.PerformanceAnalysis.animationperfd.xpc/Contents/MacOS/com.apple.PerformanceAnalysis.animationperfd
  366     1 /System/Library/Frameworks/GSS.framework/Helpers/com.apple.GSSCred
  367     1 /System/Library/CoreServices/AppleIDAuthAgent --checkpassword
  368     1 sysmond
  369     1 /System/Library/CoreServices/sharedfilelistd --enable-legacy-services
  371     1 /System/Library/Frameworks/LocalAuthentication.framework/Support/coreauthd
  373     1 /usr/libexec/securityd_service
  374     1 /usr/sbin/cfprefsd agent
  375     1 /usr/libexec/UserEventAgent (Aqua)
  377     1 /usr/sbin/distnoted agent
  379     1 /System/Library/Frameworks/CoreTelephony.framework/Support/CommCenter -L
  380     1 /usr/libexec/lsd
  381     1 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
  383     1 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
  384     1 /usr/libexec/trustd --agent
  385     1 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
  388     1 /usr/libexec/secd
  392     1 /usr/libexec/pboard
  395     1 /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/Versions/A/Support/bird
  396     1 /System/Library/PrivateFrameworks/CacheDelete.framework/deleted
  397     1 /usr/libexec/pkd
  398     1 /System/Library/PrivateFrameworks/TelephonyUtilities.framework/callservicesd
  400     1 /System/Library/Frameworks/Accounts.framework/Versions/A/Support/accountsd
  401     1 /System/Library/PrivateFrameworks/IDS.framework/identityservicesd.app/Contents/MacOS/identityservicesd
  402     1 /usr/libexec/AssetCache/AssetCache
  404     1 /System/Library/CoreServices/backupd.bundle/Contents/Resources/TMCacheDelete
  405     1 /System/Library/PrivateFrameworks/GeoServices.framework/geodMachServiceBridge
  406     1 /System/Library/PrivateFrameworks/PackageKit.framework/Resources/installd
  407     1 /System/Library/CoreServices/cloudphotosd.app/Contents/MacOS/cloudphotosd
  408     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storedownloadd
  409     1 /System/Library/PrivateFrameworks/CoreSymbolication.framework/coresymbolicationd
  410     1 /System/Library/PrivateFrameworks/PackageKit.framework/Resources/system_installd
  411     1 /System/Library/PrivateFrameworks/QuickLookThumbnailing.framework/Support/com.apple.quicklook.ThumbnailsAgent
  416     1 /usr/sbin/WirelessRadioManagerd
  418     1 /usr/libexec/secinitd
  419     1 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Support/fontd
  421     1 /System/Library/PrivateFrameworks/IMCore.framework/imagent.app/Contents/MacOS/imagent
  424     1 /System/Library/PrivateFrameworks/TCC.framework/Resources/tccd
  427     1 /System/Library/PrivateFrameworks/IMDPersistence.framework/XPCServices/IMDPersistenceAgent.xpc/Contents/MacOS/IMDPersistenceAgent
  428     1 /System/Library/CoreServices/sharedfilelistd
  429     1 /System/Library/PrivateFrameworks/UserActivity.framework/Agents/useractivityd
  430     1 /System/Library/CoreServices/mapspushd
  431     1 /System/Library/PrivateFrameworks/CalendarAgent.framework/Executables/CalendarAgent
  433     1 /System/Library/Frameworks/AddressBook.framework/Executables/ContactsAccountsService
  434     1 /usr/libexec/sharingd
  435     1 /usr/sbin/usernoted
  436     1 /System/Library/CoreServices/Dock.app/Contents/XPCServices/com.apple.dock.extra.xpc/Contents/MacOS/com.apple.dock.extra
  438     1 /System/Library/PrivateFrameworks/MessagesKit.framework/Resources/soagent.app/Contents/MacOS/soagent
  439     1 /System/Library/PrivateFrameworks/CalendarNotification.framework/Versions/A/XPCServices/CalNCService.xpc/Contents/MacOS/CalNCService
  440     1 /usr/libexec/nsurlstoraged
  442     1 /System/Library/PrivateFrameworks/AssistantServices.framework/assistantd
  443     1 /System/Library/CoreServices/FolderActionsDispatcher.app/Contents/MacOS/FolderActionsDispatcher
  445     1 /usr/libexec/spindump_agent
  447     1 /System/Library/CoreServices/SocialPushAgent.app/Contents/MacOS/SocialPushAgent
  451     1 /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter
  452     1 /System/Library/Frameworks/InputMethodKit.framework/Resources/imklaunchagent
  453     1 /System/Library/CoreServices/Siri.app/Contents/MacOS/Siri launchd
  455     1 /System/Library/Image Capture/Support/icdd
  456     1 /System/Library/CoreServices/iconservicesagent
  457     1 /System/Library/CoreServices/AppleIDAuthAgent
  460     1 /System/Library/PrivateFrameworks/AskPermission.framework/Versions/A/Resources/askpermissiond
  461     1 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent --launchd
  462     1 /System/Library/CoreServices/cloudpaird
  463     1 /System/Library/PrivateFrameworks/Noticeboard.framework/Versions/A/Resources/nbagent.app/Contents/MacOS/nbagent
  465     1 /System/Library/CoreServices/WiFiAgent.app/Contents/MacOS/WiFiAgent
  466     1 /System/Library/CoreServices/diagnostics_agent
  467     1 /System/Library/PrivateFrameworks/PassKitCore.framework/passd
  470     1 /System/Library/PrivateFrameworks/CloudPhotoServices.framework/Versions/A/Frameworks/CloudPhotosConfigurationXPC.framework/Versions/A/XPCServices/com.apple.CloudPhotosConfiguration.xpc/Contents/MacOS/com.apple.CloudPhotosConfiguration
  472     1 /Applications/iTunes.app/Contents/MacOS/iTunesHelper.app/Contents/MacOS/iTunesHelper
  473     1 /System/Library/PrivateFrameworks/CallHistory.framework/Support/CallHistoryPluginHelper
  474     1 /Applications/Kies.app/Contents/MacOS/KiesAgent.app/Contents/MacOS/KiesAgent
  475     1 /Users/mark/Library/Application Support/.FUS/fuspredownloader.app/Contents/MacOS/fuspredownloader
  476     1 /usr/libexec/taskgated -s
  478     1 /usr/libexec/keyboardservicesd
  479     1 /usr/libexec/SafariCloudHistoryPushAgent
  481     1 /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd
  482     1 /System/Library/PrivateFrameworks/CallHistory.framework/Support/CallHistorySyncHelper
  483     1 /System/Library/PrivateFrameworks/GameCenterFoundation.framework/Versions/A/gamed
  485     1 /usr/libexec/fmfd
  486     1 /System/Library/PrivateFrameworks/CloudKitDaemon.framework/Support/cloudd
  487     1 /System/Library/PrivateFrameworks/TCC.framework/Resources/tccd system
  488     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeaccountd
  489     1 /usr/libexec/nsurlsessiond
  490     1 /usr/libexec/networkserviceproxy
  492     1 /System/Library/Frameworks/Security.framework/Versions/A/Resources/CloudKeychainProxy.bundle/Contents/MacOS/CloudKeychainProxy
  493     1 /System/Library/Frameworks/Security.framework/Versions/A/Resources/KeychainSyncingOverIDSProxy.bundle/Contents/MacOS/KeychainSyncingOverIDSProxy
  497     1 /usr/sbin/filecoordinationd
  498     1 /System/Library/CoreServices/Spotlight.app/Contents/MacOS/Spotlight
  499     1 /System/Library/PrivateFrameworks/CoreParsec.framework/parsecd
  500     1 /System/Library/Frameworks/CryptoTokenKit.framework/ctkahp.bundle/Contents/MacOS/ctkahp
  501     1 /System/Library/Frameworks/LocalAuthentication.framework/Support/coreauthd
  502     1 /System/Library/Frameworks/CryptoTokenKit.framework/ctkd -tw
  503     1 /System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/XPCServices/com.apple.geod.xpc/Contents/MacOS/com.apple.geod
  505     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeassetd
  506     1 /System/Library/PrivateFrameworks/CoreWLANKit.framework/Versions/A/XPCServices/WiFiProxy.xpc/Contents/MacOS/WiFiProxy
  507     1 /System/Library/CoreServices/pbs
  508     1 /System/Library/Input Methods/DictationIM.app/Contents/MacOS/DictationIM
  509     1 /System/Library/CoreServices/NotificationCenter.app/Contents/XPCServices/com.apple.notificationcenterui.WeatherSummary.xpc/Contents/MacOS/com.apple.notificationcenterui.WeatherSummary
  510     1 /System/Library/Input Methods/PressAndHold.app/Contents/PlugIns/PAH_Extension.appex/Contents/MacOS/PAH_Extension
  511     1 /System/Library/CoreServices/Menu Extras/TextInput.menu/Contents/SharedSupport/TISwitcher.app/Contents/MacOS/TISwitcher
  513     1 /System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Support/photolibraryd
  515     1 /usr/libexec/videosubscriptionsd
  525     1 /System/Library/PrivateFrameworks/MediaRemote.framework/Support/mediaremoteagent
  526     1 /System/Library/PrivateFrameworks/ViewBridge.framework/Versions/A/XPCServices/ViewBridgeAuxiliary.xpc/Contents/MacOS/ViewBridgeAuxiliary
  527     1 /usr/libexec/captiveagent
  530     1 /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/XPCServices/ContainerMetadataExtractor.xpc/Contents/MacOS/ContainerMetadataExtractor
  531     1 /System/Library/CoreServices/CoreLocationAgent.app/Contents/MacOS/CoreLocationAgent
  533     1 /System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Frameworks/PhotoLibraryServices.framework/Versions/A/XPCServices/com.apple.photomoments.xpc/Contents/MacOS/com.apple.photomoments
  534     1 /System/Library/CoreServices/ScopedBookmarkAgent
  535     1 /System/Library/PrivateFrameworks/PhotoLibrary.framework/Versions/A/XPCServices/com.apple.PhotoIngestService.xpc/Contents/MacOS/com.apple.PhotoIngestService
  538     1 /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent
  539     1 /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent
  540     1 /System/Library/PrivateFrameworks/AssetCacheServices.framework/XPCServices/AssetCacheLocatorService.xpc/Contents/MacOS/AssetCacheLocatorService -a
  542     1 /usr/sbin/systemsoundserverd
  544     1 /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent
  545     1 /Library/Frameworks/iTunesLibrary.framework/Versions/A/XPCServices/com.apple.iTunesLibraryService.xpc/Contents/MacOS/com.apple.iTunesLibraryService
  548     1 /System/Library/PrivateFrameworks/CommunicationsFilter.framework/CMFSyncAgent.app/Contents/MacOS/CMFSyncAgent
  549     1 /usr/libexec/watchdogd
  550     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/XPCServices/com.apple.CommerceKit.TransactionService.xpc/Contents/MacOS/com.apple.CommerceKit.TransactionService
  551     1 /System/Library/PrivateFrameworks/ContactsAgent.framework/Executables/ContactsAgent
  552     1 /Applications/Google Chrome.app/Contents/MacOS/Google Chrome
  553     1 /usr/libexec/gamecontrollerd
  555     1 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Framework.framework/Helpers/crashpad_handler --monitor-self-annotation=ptype=crashpad-handler --database=/Users/mark/Library/Application Support/Google/Chrome/Crashpad --metrics-dir=/Users/mark/Library/Application Support/Google/Chrome --url=https://clients2.google.com/cr/report --annotation=channel= --annotation=plat=OS X --annotation=prod=Chrome_Mac --annotation=ver=59.0.3071.115 --handshake-fd=8
  559   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=gpu-process --field-trial-handle=1 --supports-dual-gpus=true --gpu-driver-bug-workarounds=0,1,10,24,27,38,41,49,55,63,65,66,67,68,75,76,78,86,87,88,91,94,102 --disable-gl-extensions=GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent --gpu-vendor-id=0x1002 --gpu-device-id=0x6821 --gpu-driver-vendor --gpu-driver-version --gpu-driver-date --gpu-secondary-vendor-ids=0x8086 --gpu-secondary-device-ids=0x0d26 --gpu-active-vendor-id=0x8086 --gpu-active-device-id=0x0d26 --service-request-channel-token=56FC9EC3810990C7CECC60A1B68FFBEC
  560     1 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Framework.framework/Versions/A/XPCServices/AlertNotificationService.xpc/Contents/MacOS/AlertNotificationService
  564     1 /System/Library/Frameworks/VideoToolbox.framework/Versions/A/XPCServices/VTDecoderXPCService.xpc/Contents/MacOS/VTDecoderXPCService
  569   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=0E388889151BDB31B6CDD8EC494D9B75 --lang=en-US --extension-process --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=0E388889151BDB31B6CDD8EC494D9B75 --renderer-client-id=4
  576     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdflagwriter
  577     1 /usr/libexec/WiFiVelocityAgent
  578     1 /usr/libexec/wifivelocityd
  579     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdflagwriter
  580     1 /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdate_notify_agent
  581     1 /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
  582     1 /System/Library/PrivateFrameworks/SoftwareUpdate.framework/Resources/suhelperd
  584     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storelegacy
  585     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Resources/LaterAgent.app/Contents/MacOS/LaterAgent
  595     1 /System/Library/PrivateFrameworks/PhotoAnalysis.framework/Versions/A/Support/photoanalysisd
  596     1 /System/Library/PrivateFrameworks/CoreSuggestions.framework/Versions/A/Support/suggestd
  597     1 /System/Library/PrivateFrameworks/CoreFollowUp.framework/Versions/A/Support/followupd
  599     1 /System/Library/PrivateFrameworks/AssistantServices.framework/assistant_service
  608     1 /Library/Frameworks/iTunesLibrary.framework/Versions/A/XPCServices/com.apple.iTunesLibraryService.xpc/Contents/MacOS/com.apple.iTunesLibraryService
  613     1 /usr/sbin/distnoted agent
  614     1 /usr/libexec/trustd --agent
  618     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeinstalld
  619     1 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/XPCServices/com.apple.CommerceKit.TransactionService.xpc/Contents/MacOS/com.apple.CommerceKit.TransactionService
  621     1 /usr/libexec/USBAgent
  628     1 /System/Library/PrivateFrameworks/InstallerDiagnostics.framework/Versions/A/Resources/installerdiagd
  632     1 /System/Library/Frameworks/AudioToolbox.framework/XPCServices/com.apple.audio.SandboxHelper.xpc/Contents/MacOS/com.apple.audio.SandboxHelper
  651     1 /System/Library/Services/AppleSpell.service/Contents/MacOS/AppleSpell
  652     1 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal
  663     1 /usr/bin/ssh-agent -l
  719     1 /System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/XPCServices/com.apple.geod.xpc/Contents/MacOS/com.apple.geod
  720     1 /usr/libexec/secinitd
  722     1 /usr/sbin/distnoted agent
  737     1 /Library/CoreMediaIO/Plug-Ins/DAL/AppleCamera.plugin/Contents/Resources/AppleCameraAssistant
  825     1 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/SpeechSynthesis.framework/Resources/com.apple.speech.speechsynthesisd
  833     1 /usr/sbin/spindump
  834     1 /System/Library/CoreServices/SubmitDiagInfo server-init
  843     1 /usr/libexec/syspolicyd
  844     1 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/XPCServices/com.apple.hiservices-xpcservice.xpc/Contents/MacOS/com.apple.hiservices-xpcservice
  851     1 /System/Library/PrivateFrameworks/StorageManagement.framework/Resources/diskspaced
  897   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=BA318A0CD5CD029C9549B3E7B6EF18BC --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=BA318A0CD5CD029C9549B3E7B6EF18BC --renderer-client-id=125
  911     1 /usr/sbin/netbiosd
  941     1 /Applications/Python 3.6/IDLE.app/Contents/MacOS/IDLE /Applications/Python 3.6/IDLE.app/Contents/Resources/idlemain.py
 1140   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=2A07525A75801256DC5809D645FC335A --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=2A07525A75801256DC5809D645FC335A --renderer-client-id=182
 1162     1 /System/Library/PrivateFrameworks/ProtectedCloudStorage.framework/Helpers/ProtectedCloudKeySyncing
 1163     1 /System/Library/CoreServices/EscrowSecurityAlert.app/Contents/MacOS/EscrowSecurityAlert
 1164     1 /System/Library/PrivateFrameworks/CloudServices.framework/Versions/A/XPCServices/com.apple.sbd.xpc/Contents/MacOS/com.apple.sbd
 1166     1 /System/Library/PrivateFrameworks/CoreCDP.framework/Versions/A/Resources/cdpd
 1198   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=F0AB9A08CC2C13DA86C6EFA024283EB8 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=F0AB9A08CC2C13DA86C6EFA024283EB8 --renderer-client-id=224
 1290   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=B9128D33092223B1F39D92FED13A7085 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=B9128D33092223B1F39D92FED13A7085 --renderer-client-id=256
 1311     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
 1313     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
 1316     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
 1319     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
 1324     1 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
 1327     1 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 50669
 1328     1 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 50669
 1329     1 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 50669
 1331   941 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
 1332  1331 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
 1333  1331 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
 1334  1331 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
 1506     1 /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd
 1520   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=666D4A95D5DF61DAF4FB6F9EF29AC91B --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=666D4A95D5DF61DAF4FB6F9EF29AC91B --renderer-client-id=311
 1569   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=A64A66AB5AA57FD7494CEC86339B3CE9 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=A64A66AB5AA57FD7494CEC86339B3CE9 --renderer-client-id=326
 1574     1 /System/Library/Frameworks/Foundation.framework/Versions/C/XPCServices/LookupViewService.xpc/Contents/MacOS/LookupViewService
 1576     1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/XPCServices/com.apple.DictionaryServiceHelper.xpc/Contents/MacOS/com.apple.DictionaryServiceHelper
 1577     1 /usr/libexec/DataDetectorsSourceAccess
 1582   552 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=3B82321FAECB1EE2699F455F06F1ABC0 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=3B82321FAECB1EE2699F455F06F1ABC0 --renderer-client-id=333
 1302   652 login -pf mark
 1303  1302 -bash
 1310  1303 ssh meretzkm@oit2.scps.nyu.edu
 1082   652 login -pf mark
 1083  1082 -bash
 1584  1083 ps -A -o pid ppid command

The Python script

Each line of text read from the child process ps is stored in an object of class Process in lines 50–55. And before we do that, we store one special process (the one whose PID is 0) in an object of class Process in line 48.

Lines 13–15 show the three attributes that each Process object contains. When a Process is born, lines 17–19 find its parent process, and append the newborn process to the list of its parent’s children. Of course, the process at the top of the tree (PID 0) has no parent, so we make no attempt to find its parent (line 16).

Line 17 calls the recursive function in line 21 to find the parent Process of a newborn Process. The search begins at the root Process in line 17, at the top of the tree. In other words, when line 21 is first executed, the self in that line is root. Line 24 checks if root itself is the parent of the newborn Process. If not, the for loop in lines 26–29 check if the parent of the newborn Process is among the chidren of root and their descendants. If not, line 30 returns None.

Each PID is a 32-bit integer, so it takes up to five digits to print (line 35) That’s why we indent the children of each Process an additional five spaces (line 37).

When all the input has been read in and stored in the tree, line 57 prints the whole tree starting at the root, just as line 17 searched the whole tree starting at the root. Line 35 prints the root Process, and the the for loop in lines 36–37 prints the children of root and their descendants. Note that the recursive functions find in line 21 and print in line 32 have the same structure: first they process self, and then they call themselves to process the children of self and their descendants.

tree.py

     0
          1 /sbin/launchd
              49 /usr/libexec/UserEventAgent (System)
              50 /usr/sbin/syslogd
              52 /System/Library/PrivateFrameworks/Uninstall.framework/Resources/uninstalld
              53 /usr/libexec/kextd
              54 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/FSEvents.framework/Versions/A/Support/fseventsd
              56 /System/Library/PrivateFrameworks/MediaRemote.framework/Support/mediaremoted
              59 /System/Library/CoreServices/appleeventsd --server
              60 /usr/libexec/configd
              61 /System/Library/CoreServices/powerd.bundle/powerd
              62 /usr/libexec/mobileassetd
              67 /usr/libexec/logd
              71 /usr/libexec/airportd
              73 /usr/libexec/warmd
              74 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Support/mds
              78 /System/Library/CoreServices/iconservicesd
              79 /System/Library/CoreServices/iconservicesagent
              82 /usr/libexec/diskarbitrationd
              85 /usr/libexec/coreduetd
              86 /usr/libexec/wdhelper
              91 /usr/libexec/opendirectoryd
              92 /usr/sbin/wirelessproxd
              94 /System/Library/PrivateFrameworks/ApplePushService.framework/apsd
              95 /System/Library/PrivateFrameworks/Noticeboard.framework/Versions/A/Resources/nbstated
              96 /System/Library/CoreServices/launchservicesd
              97 /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/Resources/usbmuxd -launchd
              98 /usr/sbin/securityd -i
             100 /usr/libexec/locationd
             102 /usr/libexec/DuetHeuristic-BM
             103 /usr/libexec/displaypolicyd -k 1
             104 /usr/sbin/blued
             105 autofsd
             109 /System/Library/PrivateFrameworks/GenerationalStorage.framework/Versions/A/Support/revisiond
             110 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
             111 /System/Library/CoreServices/logind
             112 /usr/sbin/KernelEventAgent
             114 /usr/libexec/hidd
             115 /usr/libexec/corebrightnessd --launchd
             116 /usr/libexec/AirPlayXPCHelper
             117 /usr/sbin/notifyd
             118 /usr/sbin/distnoted daemon
             124 /usr/sbin/cfprefsd daemon
             149 /System/Library/CoreServices/coreservicesd
             150 aslmanager
             152 /System/Library/Frameworks/Security.framework/Versions/A/XPCServices/authd.xpc/Contents/MacOS/authd
             155 /System/Library/Frameworks/PCSC.framework/Versions/A/XPCServices/com.apple.ctkpcscd.xpc/Contents/MacOS/com.apple.ctkpcscd
             159 /System/Library/Frameworks/CryptoTokenKit.framework/ctkd -s
             161 /usr/libexec/trustd
             174 /usr/libexec/sandboxd
             183 /System/Library/PrivateFrameworks/SkyLight.framework/Resources/WindowServer -daemon
             184 /usr/sbin/mDNSResponder
             189 /usr/libexec/lsd runAsRoot
             192 /usr/sbin/mDNSResponderHelper
             198 /usr/libexec/findmydeviced
             204 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mds_stores
             207 /System/Library/PrivateFrameworks/WirelessDiagnostics.framework/Support/awdd
             209 /usr/libexec/amfid
             300 /System/Library/PrivateFrameworks/AmbientDisplay.framework/Versions/A/XPCServices/com.apple.AmbientDisplayAgent.xpc/Contents/MacOS/com.apple.AmbientDisplayAgent
             302 /usr/sbin/coreaudiod
             303 /usr/sbin/systemstats --xpc
             304 /System/Library/CoreServices/CrashReporterSupportHelper server-init
             305 /usr/libexec/nsurlsessiond --privileged
             306 /usr/libexec/nehelper
             307 /usr/sbin/ntpd -c /private/etc/ntp-restrict.conf -n -g -p /var/run/ntpd.pid -f /var/db/ntp.drift
             308 /usr/libexec/corestoraged
             309 /usr/libexec/usbd
             310 /usr/libexec/thermald
             311 /System/Library/CryptoTokenKit/com.apple.ifdreader.slotd/Contents/MacOS/com.apple.ifdreader
             312 /System/Library/Frameworks/CoreMediaIO.framework/Resources/VDC.plugin/Contents/Resources/VDCAssistant
             320 /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/CVMServer
             323 /System/Library/Frameworks/CoreAudio.framework/Versions/A/XPCServices/com.apple.audio.DriverHelper.xpc/Contents/MacOS/com.apple.audio.DriverHelper
             326 /System/Library/Frameworks/Security.framework/Versions/A/XPCServices/com.apple.CodeSigningHelper.xpc/Contents/MacOS/com.apple.CodeSigningHelper
             334 /usr/libexec/symptomsd
             336 /usr/libexec/nsurlstoraged
             355 /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd
             359 /System/Library/Frameworks/CryptoTokenKit.framework/ctkahp.bundle/Contents/MacOS/ctkahp -d
             360 /usr/libexec/secinitd
             362 /System/Library/PrivateFrameworks/PerformanceAnalysis.framework/Versions/A/XPCServices/com.apple.PerformanceAnalysis.animationperfd.xpc/Contents/MacOS/com.apple.PerformanceAnalysis.animationperfd
             366 /System/Library/Frameworks/GSS.framework/Helpers/com.apple.GSSCred
             367 /System/Library/CoreServices/AppleIDAuthAgent --checkpassword
             368 sysmond
             369 /System/Library/CoreServices/sharedfilelistd --enable-legacy-services
             371 /System/Library/Frameworks/LocalAuthentication.framework/Support/coreauthd
             373 /usr/libexec/securityd_service
             374 /usr/sbin/cfprefsd agent
             375 /usr/libexec/UserEventAgent (Aqua)
             377 /usr/sbin/distnoted agent
             379 /System/Library/Frameworks/CoreTelephony.framework/Support/CommCenter -L
             380 /usr/libexec/lsd
             381 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
             383 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
             384 /usr/libexec/trustd --agent
             385 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
             388 /usr/libexec/secd
             392 /usr/libexec/pboard
             395 /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/Versions/A/Support/bird
             396 /System/Library/PrivateFrameworks/CacheDelete.framework/deleted
             397 /usr/libexec/pkd
             398 /System/Library/PrivateFrameworks/TelephonyUtilities.framework/callservicesd
             400 /System/Library/Frameworks/Accounts.framework/Versions/A/Support/accountsd
             401 /System/Library/PrivateFrameworks/IDS.framework/identityservicesd.app/Contents/MacOS/identityservicesd
             402 /usr/libexec/AssetCache/AssetCache
             404 /System/Library/CoreServices/backupd.bundle/Contents/Resources/TMCacheDelete
             405 /System/Library/PrivateFrameworks/GeoServices.framework/geodMachServiceBridge
             406 /System/Library/PrivateFrameworks/PackageKit.framework/Resources/installd
             407 /System/Library/CoreServices/cloudphotosd.app/Contents/MacOS/cloudphotosd
             408 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storedownloadd
             409 /System/Library/PrivateFrameworks/CoreSymbolication.framework/coresymbolicationd
             410 /System/Library/PrivateFrameworks/PackageKit.framework/Resources/system_installd
             411 /System/Library/PrivateFrameworks/QuickLookThumbnailing.framework/Support/com.apple.quicklook.ThumbnailsAgent
             416 /usr/sbin/WirelessRadioManagerd
             418 /usr/libexec/secinitd
             419 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Support/fontd
             421 /System/Library/PrivateFrameworks/IMCore.framework/imagent.app/Contents/MacOS/imagent
             424 /System/Library/PrivateFrameworks/TCC.framework/Resources/tccd
             427 /System/Library/PrivateFrameworks/IMDPersistence.framework/XPCServices/IMDPersistenceAgent.xpc/Contents/MacOS/IMDPersistenceAgent
             428 /System/Library/CoreServices/sharedfilelistd
             429 /System/Library/PrivateFrameworks/UserActivity.framework/Agents/useractivityd
             430 /System/Library/CoreServices/mapspushd
             431 /System/Library/PrivateFrameworks/CalendarAgent.framework/Executables/CalendarAgent
             433 /System/Library/Frameworks/AddressBook.framework/Executables/ContactsAccountsService
             434 /usr/libexec/sharingd
             435 /usr/sbin/usernoted
             436 /System/Library/CoreServices/Dock.app/Contents/XPCServices/com.apple.dock.extra.xpc/Contents/MacOS/com.apple.dock.extra
             438 /System/Library/PrivateFrameworks/MessagesKit.framework/Resources/soagent.app/Contents/MacOS/soagent
             439 /System/Library/PrivateFrameworks/CalendarNotification.framework/Versions/A/XPCServices/CalNCService.xpc/Contents/MacOS/CalNCService
             440 /usr/libexec/nsurlstoraged
             442 /System/Library/PrivateFrameworks/AssistantServices.framework/assistantd
             443 /System/Library/CoreServices/FolderActionsDispatcher.app/Contents/MacOS/FolderActionsDispatcher
             445 /usr/libexec/spindump_agent
             447 /System/Library/CoreServices/SocialPushAgent.app/Contents/MacOS/SocialPushAgent
             451 /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter
             452 /System/Library/Frameworks/InputMethodKit.framework/Resources/imklaunchagent
             453 /System/Library/CoreServices/Siri.app/Contents/MacOS/Siri launchd
             455 /System/Library/Image Capture/Support/icdd
             456 /System/Library/CoreServices/iconservicesagent
             457 /System/Library/CoreServices/AppleIDAuthAgent
             460 /System/Library/PrivateFrameworks/AskPermission.framework/Versions/A/Resources/askpermissiond
             461 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent --launchd
             462 /System/Library/CoreServices/cloudpaird
             463 /System/Library/PrivateFrameworks/Noticeboard.framework/Versions/A/Resources/nbagent.app/Contents/MacOS/nbagent
             465 /System/Library/CoreServices/WiFiAgent.app/Contents/MacOS/WiFiAgent
             466 /System/Library/CoreServices/diagnostics_agent
             467 /System/Library/PrivateFrameworks/PassKitCore.framework/passd
             470 /System/Library/PrivateFrameworks/CloudPhotoServices.framework/Versions/A/Frameworks/CloudPhotosConfigurationXPC.framework/Versions/A/XPCServices/com.apple.CloudPhotosConfiguration.xpc/Contents/MacOS/com.apple.CloudPhotosConfiguration
             472 /Applications/iTunes.app/Contents/MacOS/iTunesHelper.app/Contents/MacOS/iTunesHelper
             473 /System/Library/PrivateFrameworks/CallHistory.framework/Support/CallHistoryPluginHelper
             474 /Applications/Kies.app/Contents/MacOS/KiesAgent.app/Contents/MacOS/KiesAgent
             475 /Users/mark/Library/Application Support/.FUS/fuspredownloader.app/Contents/MacOS/fuspredownloader
             476 /usr/libexec/taskgated -s
             478 /usr/libexec/keyboardservicesd
             479 /usr/libexec/SafariCloudHistoryPushAgent
             481 /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd
             482 /System/Library/PrivateFrameworks/CallHistory.framework/Support/CallHistorySyncHelper
             483 /System/Library/PrivateFrameworks/GameCenterFoundation.framework/Versions/A/gamed
             485 /usr/libexec/fmfd
             486 /System/Library/PrivateFrameworks/CloudKitDaemon.framework/Support/cloudd
             487 /System/Library/PrivateFrameworks/TCC.framework/Resources/tccd system
             488 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeaccountd
             489 /usr/libexec/nsurlsessiond
             490 /usr/libexec/networkserviceproxy
             492 /System/Library/Frameworks/Security.framework/Versions/A/Resources/CloudKeychainProxy.bundle/Contents/MacOS/CloudKeychainProxy
             493 /System/Library/Frameworks/Security.framework/Versions/A/Resources/KeychainSyncingOverIDSProxy.bundle/Contents/MacOS/KeychainSyncingOverIDSProxy
             497 /usr/sbin/filecoordinationd
             498 /System/Library/CoreServices/Spotlight.app/Contents/MacOS/Spotlight
             499 /System/Library/PrivateFrameworks/CoreParsec.framework/parsecd
             500 /System/Library/Frameworks/CryptoTokenKit.framework/ctkahp.bundle/Contents/MacOS/ctkahp
             501 /System/Library/Frameworks/LocalAuthentication.framework/Support/coreauthd
             502 /System/Library/Frameworks/CryptoTokenKit.framework/ctkd -tw
             503 /System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/XPCServices/com.apple.geod.xpc/Contents/MacOS/com.apple.geod
             505 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeassetd
             506 /System/Library/PrivateFrameworks/CoreWLANKit.framework/Versions/A/XPCServices/WiFiProxy.xpc/Contents/MacOS/WiFiProxy
             507 /System/Library/CoreServices/pbs
             508 /System/Library/Input Methods/DictationIM.app/Contents/MacOS/DictationIM
             509 /System/Library/CoreServices/NotificationCenter.app/Contents/XPCServices/com.apple.notificationcenterui.WeatherSummary.xpc/Contents/MacOS/com.apple.notificationcenterui.WeatherSummary
             510 /System/Library/Input Methods/PressAndHold.app/Contents/PlugIns/PAH_Extension.appex/Contents/MacOS/PAH_Extension
             511 /System/Library/CoreServices/Menu Extras/TextInput.menu/Contents/SharedSupport/TISwitcher.app/Contents/MacOS/TISwitcher
             513 /System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Support/photolibraryd
             515 /usr/libexec/videosubscriptionsd
             525 /System/Library/PrivateFrameworks/MediaRemote.framework/Support/mediaremoteagent
             526 /System/Library/PrivateFrameworks/ViewBridge.framework/Versions/A/XPCServices/ViewBridgeAuxiliary.xpc/Contents/MacOS/ViewBridgeAuxiliary
             527 /usr/libexec/captiveagent
             530 /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/XPCServices/ContainerMetadataExtractor.xpc/Contents/MacOS/ContainerMetadataExtractor
             531 /System/Library/CoreServices/CoreLocationAgent.app/Contents/MacOS/CoreLocationAgent
             533 /System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Frameworks/PhotoLibraryServices.framework/Versions/A/XPCServices/com.apple.photomoments.xpc/Contents/MacOS/com.apple.photomoments
             534 /System/Library/CoreServices/ScopedBookmarkAgent
             535 /System/Library/PrivateFrameworks/PhotoLibrary.framework/Versions/A/XPCServices/com.apple.PhotoIngestService.xpc/Contents/MacOS/com.apple.PhotoIngestService
             538 /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent
             539 /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent
             540 /System/Library/PrivateFrameworks/AssetCacheServices.framework/XPCServices/AssetCacheLocatorService.xpc/Contents/MacOS/AssetCacheLocatorService -a
             542 /usr/sbin/systemsoundserverd
             544 /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent
             545 /Library/Frameworks/iTunesLibrary.framework/Versions/A/XPCServices/com.apple.iTunesLibraryService.xpc/Contents/MacOS/com.apple.iTunesLibraryService
             548 /System/Library/PrivateFrameworks/CommunicationsFilter.framework/CMFSyncAgent.app/Contents/MacOS/CMFSyncAgent
             549 /usr/libexec/watchdogd
             550 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/XPCServices/com.apple.CommerceKit.TransactionService.xpc/Contents/MacOS/com.apple.CommerceKit.TransactionService
             551 /System/Library/PrivateFrameworks/ContactsAgent.framework/Executables/ContactsAgent
             552 /Applications/Google Chrome.app/Contents/MacOS/Google Chrome
                  559 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=gpu-process --field-trial-handle=1 --supports-dual-gpus=true --gpu-driver-bug-workarounds=0,1,10,24,27,38,41,49,55,63,65,66,67,68,75,76,78,86,87,88,91,94,102 --disable-gl-extensions=GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent --gpu-vendor-id=0x1002 --gpu-device-id=0x6821 --gpu-driver-vendor --gpu-driver-version --gpu-driver-date --gpu-secondary-vendor-ids=0x8086 --gpu-secondary-device-ids=0x0d26 --gpu-active-vendor-id=0x8086 --gpu-active-device-id=0x0d26 --service-request-channel-token=56FC9EC3810990C7CECC60A1B68FFBEC
                  569 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=0E388889151BDB31B6CDD8EC494D9B75 --lang=en-US --extension-process --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=0E388889151BDB31B6CDD8EC494D9B75 --renderer-client-id=4
                  897 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=BA318A0CD5CD029C9549B3E7B6EF18BC --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=BA318A0CD5CD029C9549B3E7B6EF18BC --renderer-client-id=125
                 1004 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=0CC46FFB8670E90175E6CC3668B7F738 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=0CC46FFB8670E90175E6CC3668B7F738 --renderer-client-id=145
                 1140 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=2A07525A75801256DC5809D645FC335A --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=2A07525A75801256DC5809D645FC335A --renderer-client-id=182
                 1198 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=F0AB9A08CC2C13DA86C6EFA024283EB8 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=F0AB9A08CC2C13DA86C6EFA024283EB8 --renderer-client-id=224
                 1290 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=B9128D33092223B1F39D92FED13A7085 --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=B9128D33092223B1F39D92FED13A7085 --renderer-client-id=256
                 1520 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Helper.app/Contents/MacOS/Google Chrome Helper --type=renderer --field-trial-handle=1 --primordial-pipe-token=666D4A95D5DF61DAF4FB6F9EF29AC91B --lang=en-US --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --blink-settings=disallowFetchForDocWrittenScriptsInMainFrame=false,disallowFetchForDocWrittenScriptsInMainFrameOnSlowConnections=false --enable-pinch --num-raster-threads=4 --enable-zero-copy --enable-gpu-memory-buffer-compositor-resources --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,34037;0,11,34037;0,12,34037;0,13,3553;0,14,3553;0,15,3553;0,16,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,34037;1,11,34037;1,12,34037;1,13,3553;1,14,3553;1,15,3553;1,16,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,34037;2,11,34037;2,12,34037;2,13,3553;2,14,3553;2,15,3553;2,16,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,34037;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,34037;3,13,34037;3,14,3553;3,15,34037;3,16,34037;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,34037;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,34037;4,13,34037;4,14,3553;4,15,34037;4,16,34037 --service-request-channel-token=666D4A95D5DF61DAF4FB6F9EF29AC91B --renderer-client-id=311
             553 /usr/libexec/gamecontrollerd
             555 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Framework.framework/Helpers/crashpad_handler --monitor-self-annotation=ptype=crashpad-handler --database=/Users/mark/Library/Application Support/Google/Chrome/Crashpad --metrics-dir=/Users/mark/Library/Application Support/Google/Chrome --url=https://clients2.google.com/cr/report --annotation=channel= --annotation=plat=OS X --annotation=prod=Chrome_Mac --annotation=ver=59.0.3071.115 --handshake-fd=8
             560 /Applications/Google Chrome.app/Contents/Versions/59.0.3071.115/Google Chrome Framework.framework/Versions/A/XPCServices/AlertNotificationService.xpc/Contents/MacOS/AlertNotificationService
             564 /System/Library/Frameworks/VideoToolbox.framework/Versions/A/XPCServices/VTDecoderXPCService.xpc/Contents/MacOS/VTDecoderXPCService
             576 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdflagwriter
             577 /usr/libexec/WiFiVelocityAgent
             578 /usr/libexec/wifivelocityd
             579 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdflagwriter
             580 /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdate_notify_agent
             581 /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
             582 /System/Library/PrivateFrameworks/SoftwareUpdate.framework/Resources/suhelperd
             584 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storelegacy
             585 /System/Library/PrivateFrameworks/CommerceKit.framework/Resources/LaterAgent.app/Contents/MacOS/LaterAgent
             595 /System/Library/PrivateFrameworks/PhotoAnalysis.framework/Versions/A/Support/photoanalysisd
             596 /System/Library/PrivateFrameworks/CoreSuggestions.framework/Versions/A/Support/suggestd
             597 /System/Library/PrivateFrameworks/CoreFollowUp.framework/Versions/A/Support/followupd
             599 /System/Library/PrivateFrameworks/AssistantServices.framework/assistant_service
             608 /Library/Frameworks/iTunesLibrary.framework/Versions/A/XPCServices/com.apple.iTunesLibraryService.xpc/Contents/MacOS/com.apple.iTunesLibraryService
             613 /usr/sbin/distnoted agent
             614 /usr/libexec/trustd --agent
             618 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/storeinstalld
             619 /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/XPCServices/com.apple.CommerceKit.TransactionService.xpc/Contents/MacOS/com.apple.CommerceKit.TransactionService
             621 /usr/libexec/USBAgent
             628 /System/Library/PrivateFrameworks/InstallerDiagnostics.framework/Versions/A/Resources/installerdiagd
             632 /System/Library/Frameworks/AudioToolbox.framework/XPCServices/com.apple.audio.SandboxHelper.xpc/Contents/MacOS/com.apple.audio.SandboxHelper
             651 /System/Library/Services/AppleSpell.service/Contents/MacOS/AppleSpell
             652 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal
                 1082 login -pf mark
                      1083 -bash
                           1554 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python tree.py
                                1555 ps -A -o pid ppid command
                 1302 login -pf mark
                      1303 -bash
                           1310 ssh meretzkm@oit2.scps.nyu.edu
             663 /usr/bin/ssh-agent -l
             719 /System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/XPCServices/com.apple.geod.xpc/Contents/MacOS/com.apple.geod
             720 /usr/libexec/secinitd
             722 /usr/sbin/distnoted agent
             737 /Library/CoreMediaIO/Plug-Ins/DAL/AppleCamera.plugin/Contents/Resources/AppleCameraAssistant
             825 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/SpeechSynthesis.framework/Resources/com.apple.speech.speechsynthesisd
             833 /usr/sbin/spindump
             834 /System/Library/CoreServices/SubmitDiagInfo server-init
             843 /usr/libexec/syspolicyd
             844 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/XPCServices/com.apple.hiservices-xpcservice.xpc/Contents/MacOS/com.apple.hiservices-xpcservice
             851 /System/Library/PrivateFrameworks/StorageManagement.framework/Resources/diskspaced
             911 /usr/sbin/netbiosd
             941 /Applications/Python 3.6/IDLE.app/Contents/MacOS/IDLE /Applications/Python 3.6/IDLE.app/Contents/Resources/idlemain.py
                 1331 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
                      1332 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
                      1333 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
                      1334 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 51632
            1162 /System/Library/PrivateFrameworks/ProtectedCloudStorage.framework/Helpers/ProtectedCloudKeySyncing
            1163 /System/Library/CoreServices/EscrowSecurityAlert.app/Contents/MacOS/EscrowSecurityAlert
            1164 /System/Library/PrivateFrameworks/CloudServices.framework/Versions/A/XPCServices/com.apple.sbd.xpc/Contents/MacOS/com.apple.sbd
            1166 /System/Library/PrivateFrameworks/CoreCDP.framework/Versions/A/Resources/cdpd
            1311 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
            1313 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
            1316 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
            1319 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
            1324 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker -s mdworker -c MDSImporterWorker -m com.apple.mdworker.shared
            1327 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 50669
            1328 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 50669
            1329 /Library/Frameworks/Python.framework/Versions/3.6/Resources/Python.app/Contents/MacOS/Python -c __import__('idlelib.run').run.main(True) 50669
            1506 /System/Library/Frameworks/QuickLook.framework/Resources/quicklookd.app/Contents/MacOS/quicklookd
            1540 /usr/sbin/ocspd
            1552 /Library/Application Support/Adobe/ARMDC/Application/Acrobat Update Helper.app/Contents/MacOS/Acrobat Update Helper

Things to try

  1. The directories on a computer are oganized into a family tree just like the processes. Print the tree of directories, indented the same way we printed the tree of processes. See os.walk in Intersect.

  2. What other things are organized into a tree? Hint:
    .edu
    .nyu.edu
    .scps.nyu.edu
    oit2.scps.nyu.edu